Technical Note

Use with VxWorks 7

Issue 1.0

This Technical Note provides information to help setup and install Cantata into an existing Wind River Workbench/VxWorks installation.

This information is correct for Cantata using Wind River Workbench 4.0 under Windows. Cantata does not support Workbench 4.0 on Linux, or the ICC tool chain of VxWorks 7.0.
Cantata Technical Note: Use with VxWorks 7

Contents

1 Introduction ........................................................................................................................................3
2 Installing Cantata ............................................................................................................................3
  2.1 Product installation ......................................................................................................................3
    2.1.1 Installing into Workbench .....................................................................................................3
    2.1.2 Restarting Workbench ..........................................................................................................4
3 Deploying Cantata for VxWorks .......................................................................................................6
  3.1 The Deployment Wizard ..............................................................................................................6
  3.2 The Deployment Process .............................................................................................................6
4 What’s different in Cantata for Workbench .....................................................................................8

Copyright Notice

Subject to any existing rights of other parties, QA Systems GmbH is the owner of the copyright of this document. No part of this document may be copied, reproduced, stored in a retrieval system, disclosed to a third party or transmitted in any form or by any means, electronic, mechanical, photocopying, recording or otherwise, without the prior written permission of QA Systems GmbH.

© Copyright QA Systems GmbH 2020
1 Introduction

This document contains chapters that will help install and setup Cantata for use within Wind River Workbench. In order to get the full benefit of this, it is recommended that each chapter is followed and the steps detailed are completed before moving onto the next chapter. If this is not done, then it is likely that subsequent steps will not work as expected in this document.

2 Installing Cantata

This section gives details for how to install the Cantata product into the Wind River Workbench IDE.

2.1 Product installation

In order to install the Cantata product, a zipped Eclipse P2 update site archive will be required. This will be made available to you by your supplier, or through the Wind River Marketplace.

The default name of this update site is “CantataForWorkbench4.0.zip”, and it should be around 56MB in size. If the package you have been provided is not at least this size, then it may not contain all the required files for installing Cantata.

2.1.1 Installing into Workbench

Before proceeding with the installation, ensure that Workbench can access the internet, and that the available update sites include the basic ones for the ‘Kepler’ version of Eclipse. To do this:

1) In Workbench, select Window -> Preferences -> Install/Update -> Available Software Sites
2) Check the sites that mention ‘Kepler’ are enabled.

The Cantata product should be installed into Workbench by following the steps below:

1) Select Help -> Install New Software...
2) Click the ‘Add...’ button, and then select ‘Archive...’. Browse to the location of the Cantata zip file provided by your supplier. Select OK to close the dialog.
3) There should now be two ‘Cantata’ items in the list with check boxes next to them.
   o If there are not, deselecting the ‘Group Items by Category’ option towards the bottom of the dialog should allow them to be displayed.
4) Check both boxes, and click ‘Finish’ to begin installing Cantata.
5) A licence agreement will be shown, for Cantata, and for any other dependent plugins that will be installed. This must be agreed to in order to continue the installation. Once agreed, Cantata will be installed into Workbench. Please be patient, as this may take a few minutes, and will require Workbench to be restarted when finished (this will be prompted).
6) When Workbench is restarted, you will be prompted to complete the second stage of the installation process. This is detailed in section 2.1.2 below.
Cantata Technical Note: Use with VxWorks 7

2.1.2 Restarting Workbench

The first time Workbench is started after the steps in section 2.1.1 have been completed, you will be prompted to perform stage 2 of the installation. This is necessary in order to make Cantata usable inside Workbench, and will set up the basic settings and configurations such that Cantata can be used with the Simulator provided by Workbench 4.0.

The steps to complete are as follow:
A dialog will be shown indicating this additional setup is required. Click ‘OK’ to start this process.

> It is very quick, and does not require much input
> Note that an error will be displayed in the Workbench Console view when this dialog is raised. This is the check that Cantata does to determine whether additional installation steps are required, and can be ignored.
> Clicking ‘Cancel’ will mean the final setup steps are not completed. Cantata will not be ready for use, and you will be prompted again the next time Workbench is started.

The next dialog asks for a base directory of where to put the files needed by Cantata.

Choose a suitable directory where you wish to put your Cantata installation
For example C:\qa_systems\cantata
Ensure the folder you wish to use is selected in the tree view before clicking OK

When ‘OK’ is clicked, the main Cantata executables and header files will be extracted into the location you specified, and Workbench will be configured to use this directory as the base for your Cantata installation.
Cantata Technical Note: Use with VxWorks 7

The next step will install the pre-configured target libraries supplied with Cantata for the VxWorks platforms currently installed into your Workbench environment. To help do this a dialog is raised that asks for the base directory of your compiler toolchain.

> If Workbench is installed in the default location (i.e. C:\WindRiver), then you should be able to click ‘OK’ straight away.
> If Workbench is installed elsewhere, then use the browse button to locate the base directory of your Wind River installation.

When ‘OK’ is clicked, Cantata will install all the relevant pre-configured target libraries.

The final step, shows a dialog asking you to place your Cantata licence file into a given directory, and call it ‘license.lic’. This is required in order for Cantata to successfully obtain a licence.

If you do not have your Cantata licence file at this stage, that does not matter. The dialog will be shown the next time Workbench is started to remind you where to place the licence when you have received it.

Cantata is now ready to use with the pre-configured simulator provided within Workbench 4.0 and VxWorks 7.0.

Please refer to the Cantata User Guide for details about how to use the product. See Help -> Help Contents -> Cantata to access this.
3 Deploying Cantata for VxWorks

Cantata provides all the tools necessary for end users to deploy the product for their own custom build specs. Therefore if you are not using the simulator provided with VxWorks, then additional work is required to set this up.

Due to the level of integration Cantata provides with Wind River Workbench, it is relatively straightforward to deploy Cantata for VxWorks on either a customised simulator or for target hardware.

This section will outline the procedure for deploying Cantata from within Workbench. If you encounter problems, please contact your supplier.

3.1 The Deployment Wizard

Cantata provides an intuitive, easy-to-use Wizard to set up a Deployment Project that is used to control the deployment process.

To begin the process, select File -> New -> Project... -> Cantata -> Wind River Platform Deployment Project and click next.

This will open the Deployment Wizard. Complete the wizard as follows:

7) Choose a project name on the first page. The default is fine, but change it if desired
8) The second page allows the selection of the target type for the deployment
   o Platform – Select the target platform, e.g. VxWorks 7.0
   o Source Build Project – Select the VxWorks Source Build project to use as a base
   o Type – Select the type for the deployment, e.g. Real Time Process (RTP)
   o Build Spec – Select the build spec that should be used for the deployment, e.g. vsb_bsp6x_simpc_SIMNTgnu
   o Finally, select the language that will be tested with this deployment.
9) Select finish.

3.2 The Deployment Process

Once ‘Finish’ is selected on the Deployment Wizard, the Cantata build job is started. This controls the deployment, and will periodically prompt for inputs and actions.

There are 4 stages to the deployment process all of which are completed by the Cantata build job. These are:

10) Generate the Cantata configuration for the chosen settings
11) Build the Cantata library with the chosen settings
12) Build the Cantata Deployment Tests (these check that the built library functions as expected)
13) Run the Deployment Tests.

During stages 1 and 4 the process will prompt for something to be executed on the target. When this occurs, right click the project mentioned in the dialog and select the ‘Run VxWorks ...’ Item that is
Cantata Technical Note: Use with VxWorks 7

for the project type selected, e.g. Select ‘Run VxWorks Real Time Process’ if RTP was selected in the Deployment Wizard. Be sure to select the Launch Configuration and/or target connection for the target being used.

During execution, a console will appear and display some text. It is this text that the dialog box refers to when it asks for ‘Success’ or ‘Failure’. Please note that if ‘Failure’ is displayed, this is not a problem, it is just part of the process Cantata goes through in order to determine the features of the compiler/target being used.

**Note:** When execution has completed (the very top section of the console says <terminated>) be sure to disconnect from the target. Failure to do so, could impact the execution result of subsequent tests.

When executing the Deployment Tests (stage 4 as described above) there will be no visible output to the console.

Once the Cantata build job has completed, the page of the Deployment Editor that is displayed should contain a table with 4 rows of green text. If this is the case, it means the deployment was successful and is now ready to use. The created project can be deleted now.

If there are some errors, one or more of the rows in this table will contain red text and should be investigated. For more information about why the process failed there is the Messages section on the same page as the table, or there will be a log file located in `cpp_tmp/cpp_log.txt` in the deployment project created. If in doubt as to how the problem should be solved, please contact your supplier, providing them with a zipped up copy of the deployment project and any related projects created by the Cantata build job.
4 What’s different in Cantata for Workbench

All features of Cantata are available within the Workbench IDE, and the method of actually using the tool is mostly identical to the method described in the User Guide and Reference Manuals. However there are some slight changes:

> The default setting of using Cantata Makefiles, does not affect the way tests should be built within Workbench (i.e. there is no Cantata Build Configuration to enable)

> To build a generated test, Cantata creates a Build Target within the project that can be built independently of all other Build Targets. To build and run a test, its associated build target should be used.

> The Cantata Makefiles provide a method for automated regression testing of all tests for a project. To use this, open a Workbench development shell (right click the tests directory in the project and select Open Wind River..... Development Shell. To use the makefiles type:

  “make clean” – This will clean all Cantata tests
  “make all” – This will build all Cantata tests
  “make EXECUTE=1 all” – This will build all tests (if necessary) and run them
  “make help” – This will display some additional help into about the use of the Cantata Makefiles

> An additional ‘Target Preferences’ page is created in the Installation Details preferences for Cantata. This allows the default output directory to be set for all projects.

> An additional ‘Target Options’ tab is provided in the Cantata section of the project properties. This allows Workbench specific settings to be changed on a per project basis.